Dear Valued Clients,

Please be informed that we will be performing a maintenance on Windows Shared hosting server to upgrade the PHP version. This upgrade will require an approximate 150 to 180 Minutes of a maintenance window. Following is the scheduled maintenance:

Maintenance Date / Time / Server:
Server: Wampa 72.18.130.113
Date: 8th Sep 2017
Time: 12.01 AM MDT

Server: Watto 72.18.130.114
Date: 11th Sep 2017
Time: 12.01 AM MDT

Server: R2D2 72.18.130.115
Date: 12th Sep 2017
Time: 12.01 AM MDT

Server: Rotta 72.18.130.116
Date: 13th Sep 2017
Time: 12.01 AM MDT

Server: Stormtrooper 72.18.130.118
Date: 14th Sep 2017
Time: 12.01 AM MDT

Maintenance Description:
PHP 5.3 has become obsolete. As a result, we're beginning the process to upgrade PHP 5.3 to PHP 5.6 on our infrastructure. Simultaneously, we highly encourage customers to switch to PHP 5.6 as well.

Maintenance Impact:
1. For customers who are using custom script/Open Source application that runs Zend Optimizer, Zend Optimizer will be replaced by Zend Guard Loader in PHP 5.6 and above. You should upgrade your script to support Zend Guard Loader.

2. Customers who are running old versions of applications should upgrade to the latest versions IMMEDIATELY. If old versions of any applications are running, their is a high probability you will encounter incompatibility issues causing your site to stop running or not displaying proper content. Please check your applications and upgrade to the latest versions.

3. For customers who are using a custom script/Open Source application that runs the following PHP features. The iconv and mbstring configuration options related to encoding have been deprecated in favor of default_charset. The deprecated options are:

iconv.input_encoding
iconv.output_encoding
iconv.internal_encoding
mbstring.http_input
mbstring.http_output
mbstring.internal_encoding

If any of your script contains the above features, you should replace it with alternative feature.

4. PHP Incompatible changes. If you are using any of the incompatible changes listed by PHP, you should replace the changes with alternative features.

5. PHP Removed Extension. If you are using any of the removed extensions, you may replace it with alternative features in newer versions.

6. This upgrade is mandatory and it’s not reversible once the process is done.

7. If you're unsure of all the above changes, you are advised to seek the help of your in-house webmaster/IT personnel. Alternatively, you may contact our Support Helpdesk for more information.

During this maintenance window, the website (and other data) hosted on the mentioned web server will be inaccessible. However, your mail services will be intact and will be operational during this maintenance. We will be doing our best to ensure that service is resumed as quickly as possible.

Technical Assistance:
If you have any questions feel free to write an email to support@stpwebhosting.com.

We thank you for the co-operation.

Sincerely,
STPWebHosting.com
Management

Friday, September 8, 2017

« Back